What do I need to change to prevent this denim looking grain/noise in my product photos?

I’m an amateur and I’m reading everything that I can to learn how to take decent product photos and get the best out of the equipment that I have…
My question is specifically, what is likely causing this particular issue described below? I’m looking for settings and concepts that I’m just not certain of yet, but if the final answer is to buy better equipment, then that’s the push that I need to do so…

I’m shooting with a Nikon P80. I am using a white backdrop and umbrella-softened light. I attempted manual settings all over the place but everything comes out some sort of wrong. I’ve switched over to automatic-everything-mode and I get this “denim-like” noise/grain on portions of my photo. I’m struggling with the retouching to make it look good, however I feel that I should be preventing it from happening in the first place. Is it technique???

Below, find a composite where I’ve put together the troubling section of the image below. This includes a pull from the original (upper left) and after I’ve used LightRoom to adjust lighting and remove noise. Noise reduction helps a bit, but doesn’t solve my problem. I’m also attaching the original image that came from the camera.

So for those who’ve come before me, what can I do??? Thanks much!

Composite:

Composite Image

https://www.amazon.com/clouddrive/share/4Xcc4FDxX9vyU8Pkl4AMlWbqY8RL4UPnbHCbc8D6btH

Original photo: https://www.amazon.com/clouddrive/share/GOuVYF27k68LdDPNQ2TnXFNjhKxVQCvEhlXF2HnuyXi